This set of forums is an archive of our old CGI-Based forum platform (UBB.Classic) that was never imported to our current forum (UBB.threads); as such, no new postings or registrations are allowed here.

Please instead direct all questions and postings to the our current forum here.
Previous Thread
Next Thread
Print Thread
#27125 June 8th, 2005 at 11:42 PM
Joined: Jun 2005
R
Redaunt Offline OP
Junior Member
OP Offline
Junior Member
R
Joined: Jun 2005
I am a new gardener who has planted two each of jalepeno and habenero plants, along with two tomato plants and a couple of herb plants. My question is: Why are my pepper plants suddenly turning a yellowish/pale green color? Is it something with too much nitrogen in the soil? Over or under watering? My other plants are thriving, and while the pepper plants aren't looking the best, they are still flowering and beginning to produce small peppers. Does anyone have an idea on how I can begin to trouble shoot this problem?
Thanks for any advice!

#27126 June 9th, 2005 at 03:16 AM
Joined: Apr 2003
Compost Queen!
Offline
Compost Queen!
Joined: Apr 2003
Jen,
peppers can be sometimes testy...

Can I ask you a bit about has it been raining
alot or are you watering alot/??
Sometimes, when you water alot or it rains alot
it tends to wash away nutrients....really fast
and the plant doesn't have time to utilize any
good stuff from the dirt...

Or, it could be the lack of calcium or magnesium in the soil...

If you go get some EPSOM SALTS, and sprinkle it around the drip line around the base of the plant, and scratch it in...and give it a good watering..

I have heard of some planting tips...
When planting peppers, dig deeper than the
actual hole for the plant...

and put in either..........

a banana peel
a pack of matches
a bunch of crushed egg shells...

Then cover in with a little bit of dirt and then plant the plant in the hole.

#27127 June 9th, 2005 at 05:51 AM
Joined: Apr 2005
P
Member
Offline
Member
P
Joined: Apr 2005
Jen,

It's not too much nitrogen. Too much nitrogen would cause the plants to be nice and green with a lot of leaves, but not many blossoms. Yellow leaves with blossoms may be a nitrogen deficiency, or what Weezie said.

#27128 June 9th, 2005 at 10:16 AM
Joined: Jun 2005
LMT Offline
Member
Offline
Member
Joined: Jun 2005
Since they are flowering and fruiting I would look for a fertilizer with a high middle number, often called a bloom enhancer. I use a little 10-60-10 at half strength just before flowering.

If your ground is wet they could be starved for oxygen.

#27129 June 9th, 2005 at 11:17 AM
Joined: Sep 2004
Member
Offline
Member
Joined: Sep 2004
Here's a site with fotos showing nutrient deficiencies in tomatoes.
http://www.plantphys.net/printer.php?ch=5&id=289
I reckon your plants are either missing something, so require a trace elements fertiliser or the Ph is less than 6 or drainage is insufficient. It could also be any combination of these probs. So first, check the drainage. Is it OK? Rightoh, now the other plants in the same area. Are they showing any sign of similar probs? You suggest no, they are quite OK.
The tomatoes are of the same genus, they require similar conditions. So i reckon the Ph is ballpark. That leaves me with a nutrient deficiency, possibly thru bad drainage. For new leaves to be yellow suggests an iron deficiency. (This can happen in waterlogged soil) I'm not a big fan of correcting deficiencies with straight additives. Unless you know what you're doing you can really stuff it all up. I reckon go for an organic liquid fertiliser with trace elements , like fish emulsion. Esp make sure there is iron in there. This all depends on your drainage being adequate. Am i mixing you up? It might sound a bit complex but it's just my explanations that get complex. Oh for the gift of language:)


Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Release build 20201027)
Responsive Width:

PHP: 7.3.20 Page Time: 0.018s Queries: 23 (0.012s) Memory: 0.7436 MB (Peak: 0.7994 MB) Data Comp: Zlib Server Time: 2021-04-18 21:21:04 UTC
Valid HTML 5 and Valid CSS