Previous Thread
Next Thread
Print Thread
Rate Thread
#144443 Oct 22nd, 2007 at 10:15 AM
Joined: Oct 2007
Posts: 2
VSJ Offline OP
Member
OP Offline
Member
Joined: Oct 2007
Posts: 2
Many of my plants have brown/red colored leaves. They look terrible. The new growth looks good but doesn't stay that way. The sources I have checked don't list liriope as bothered by anything. Suggestions?

VSJ #144493 Oct 22nd, 2007 at 02:01 PM
Joined: Jun 2003
Posts: 29,331
Likes: 47
Northern Star
20k Posts
Online Crazy
Northern Star
20k Posts
Joined: Jun 2003
Posts: 29,331
Likes: 47
Hi and welcome VSJ.

Since it is affecting many of your plants, I am wondering if it could be from your water. My aunt had the same problem with hers from excess chlorine. She's boil her water then leave it sit 24 hours before watering her plants with it.


~~Tam~ You can bury all your troubles by digging in the dirt.
[Linked Image from agardenersforum.com]
[Linked Image from agardenersforum.com]

Link Copied to Clipboard
Seasonal Ticker
Gardening Links
Gardening in September
Gardening in October
Gardening in November


Shop at Amazon and Support AGF
Are you shopping online? Click this link first and A Gardeners Forum will receive a commission for your referral at Amazon.com (shopping through this link to Amazon will not have any impact on your prices at Amazon).
Like Us on Facebook
Forum Statistics
Forums65
Topics14,258
Posts237,633
Average Daily Posts6
Members15,977
Most Online10,356
Nov 2nd, 2019
Top Posters(30 Days)
Tina 31
Random Gallery Image
Powered by UBB.threads™ PHP Forum Software 7.7.5