Previous Thread
Next Thread
Print Thread
Rate Thread
#144443 Oct 22nd, 2007 at 10:15 AM
Joined: Oct 2007
Posts: 2
VSJ Offline OP
Member
OP Offline
Member
Joined: Oct 2007
Posts: 2
Many of my plants have brown/red colored leaves. They look terrible. The new growth looks good but doesn't stay that way. The sources I have checked don't list liriope as bothered by anything. Suggestions?

VSJ #144493 Oct 22nd, 2007 at 02:01 PM
Joined: Jun 2003
Posts: 29,034
Likes: 36
Northern Star
20k Posts
Online Crazy
Northern Star
20k Posts
Joined: Jun 2003
Posts: 29,034
Likes: 36
Hi and welcome VSJ.

Since it is affecting many of your plants, I am wondering if it could be from your water. My aunt had the same problem with hers from excess chlorine. She's boil her water then leave it sit 24 hours before watering her plants with it.


~~Tam~~Those who think country life is simple....have never lived on a farm.
[Linked Image]
[Linked Image]

Link Copied to Clipboard
Seasonal Ticker
Gardening Links
Gardening in March
Gardening in April
Gardening in May


Shop at Amazon and Support AGF
Are you shopping online? Click this link first and A Gardeners Forum will receive a commission for your referral at Amazon.com (shopping through this link to Amazon will not have any impact on your prices at Amazon).
Like Us on Facebook
Forum Statistics
Forums65
Topics14,244
Posts236,532
Average Daily Posts7
Members15,968
Most Online10,356
Nov 2nd, 2019
Top Posters(30 Days)
Tina 66
NannaH 2
netty 1
Random Gallery Image
Powered by UBB.threads™ PHP Forum Software 7.7.5