Previous Thread
Next Thread
Print Thread
Rate Thread
#108833 Aug 13th, 2007 at 08:49 AM
Joined: Aug 2007
Posts: 3
praj26 Offline OP
Member
OP Offline
Member
Joined: Aug 2007
Posts: 3


Hi friends...I have certain questions related my plants that ?I bought some weeks ago. I have bought pot mums...chrysantheme yellow and white...but they are faded now and show no good flowers...I am worried about them...Any special care should be taken for them to bloom??

Please help... :wink:

PRAJ

Last edited by praj26; Aug 13th, 2007 at 09:01 AM.
praj26 #108905 Aug 13th, 2007 at 09:41 AM
Joined: Jul 2003
Posts: 2,847
2k Posts
Offline
2k Posts
Joined: Jul 2003
Posts: 2,847
I don't know your location...but imagne is north if seeing mums out already.When you buy mums you want to buy mums with lots of buds.They are useualy grown under forced high fertilier condtions before shipping.you can remove the spent blooms.do you still have buds on plant to bloom?be sure you've removed that foil thingy they stick those pots in so its draining.most times you can lift plant from pot to inspect the roots to see if is root bound or not.


[Linked Image from agardenersforum.com]

I will age ungracefully until I become an old woman in a small garden..doing whatever the Hell I want!
njoynit #108929 Aug 13th, 2007 at 10:11 AM
Joined: Aug 2007
Posts: 3
praj26 Offline OP
Member
OP Offline
Member
Joined: Aug 2007
Posts: 3
hiii...

thnx for the reply... well i am in Michigan...

Yes there are lots of buds on the plant right now.....but now they have started becoming dead i suppose....so i am more concern....as when i bought them...they were really beautiful....is there any fertiliser that i should be using or any different kind of soil we get in the stores??

would be grateful for the reply...

PRAJ

praj26 #109092 Aug 13th, 2007 at 12:18 PM
Joined: Jul 2003
Posts: 2,847
2k Posts
Offline
2k Posts
Joined: Jul 2003
Posts: 2,847
is the soil in the pot feel like mostly peat?If its mostly peat its drying too fast.you can repot it into regular potting mix& give some fertilizer.
starting to become dead.as in limp or getting brown.hows the light where they are sitting?


[Linked Image from agardenersforum.com]

I will age ungracefully until I become an old woman in a small garden..doing whatever the Hell I want!
njoynit #109556 Aug 14th, 2007 at 04:58 AM
Joined: Aug 2007
Posts: 3
praj26 Offline OP
Member
OP Offline
Member
Joined: Aug 2007
Posts: 3
hey....

The buds are starting to getting brown. The light where they are kept is all bright. I have kept them in my patio....where its full sunlight and exposed to it. Yes, and now I will try to resoil it...i guess the thing u said of peat could be the reason. I need to go to the nursery it seems for the soil and fertiliser now.

I really need to see them blossom again :)


Link Copied to Clipboard
Seasonal Ticker
Gardening Links
Gardening in December
Gardening in January
Gardening in February


Shop at Amazon and Support AGF
Are you shopping online? Click this link first and A Gardeners Forum will receive a commission for your referral at Amazon.com (shopping through this link to Amazon will not have any impact on your prices at Amazon).
Like Us on Facebook
Forum Statistics
Forums65
Topics14,224
Posts235,721
Average Daily Posts8
Members15,950
Most Online10,356
Nov 2nd, 2019
Top Posters(30 Days)
JunieGirl 101
Tina 72
Random Gallery Image
Powered by UBB.threads™ PHP Forum Software 7.7.5